思科交换机配置「思科交换机配置access命令」

导读大家好,乐乐来为大家解答问题。思科交换机配置,思科交换机配置access命令很多人还不知道,现在让我们一起来了解下吧!今天我们一起来详细的了解思科交换机的配置命令。一、思科交换机基本...

大家好,乐乐来为大家解答问题。思科交换机配置,思科交换机配置access命令很多人还不知道,现在让我们一起来了解下吧!

今天我们一起来详细的了解思科交换机的配置命令。


一、思科交换机基本配置命令


1:进入特权模式 enable

switchu0026gt; enable

switch#


2:进入全局配置模式 configure terminal

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#


3:交换机命名 hostname aptech2950 以 aptech2950 为例

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#hostname aptch-2950

aptech2950(conf)#


4:配置使能口令 enable password cisco 以 cisco 为例

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#hostname aptch2950

aptech2950(conf)# enable password cisco


5:配置使能密码 enable secret ciscolab 以 cicsolab 为例

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#hostname aptch2950

aptech2950(conf)# enable secret ciscolab


6:创建多个vlan

1、创建多个VLAN

Switchu0026gt;enable (进入特权模式)

Switch#vlan data (进入vlan配置模式)

Switch(vlan)#vlan 10 name IT (划分vlan10,名称为IT)

Switch(vlan)#vlan 20 name HR (划分vlan20,名称为HR)

Switch(vlan)#vlan 30 name FIN (划分vlan30,名称为FIN)

Switch(vlan)#vlan 40 name LOG (划分vlan40,名称为LOG)

Switch(vlan)#exit


7:设置 vlan 1

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#hostname aptch2950

aptech2950(conf)# interface vlan 1

aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口 ip 和子网掩码


aptech2950(conf-if)#no shut 是配置处于运行中

aptech2950(conf-if)#exit

aptech2950(conf)#ip default-gateway 192.168.254 设置网关地址


8:进入交换机某一端口 interface fastehernet 0/17 以 17 端口为例

switchu0026gt; enable

switch#c onfigure terminal

switch(conf)#hostname aptch2950

aptech2950(conf)# interface fastehernet 0/17

aptech2950(conf-if)#


9:查看命令 show

switchu0026gt; enable

switch# show version 察看系统中的所有版本信息

show interface vlan 1 查看交换机有关 ip 协议的配置信息

show running-configure 查看交换机当前起作用的配置信息

show interface fastethernet 0/1 察看交换机 1 接口具体配置和统计信息

show mac-address-table 查看 mac 地址表

show mac-address-table aging-time 查看 mac 地址表自动老化时间


10:交换机恢复出厂默认恢复命令

switchu0026gt; enable

switch# erase startup-configure

switch# reload


11:双工模式设置

switchu0026gt; enable

switch#c onfigure terminal

switch2950(conf)#hostname aptch-2950

aptech2950(conf)# interface fastehernet 0/17 以 17 端口为例

aptech2950(conf-if)#duplex full/half/auto 有 full , half, auto 三个可选


11:cdp 相关命令

switchu0026gt; enable

switch# show cdp 查看设备的 cdp 全局配置信息

show cdp interface fastethernet 0/17 查看 17 端口的 cdp 配置信息

show cdp traffic 查看有关 cdp 包的统计信息

show cdp nerghbors 列出与设备相连的 cisco 设备



12:交换机 telnet 远程登录设置:

switchu0026gt;en

switch#c onfigure terminal

switch(conf)#hostname aptech-2950

aptech2950(conf)#enable password cisco 以 cisco 为特权模式密码

aptech2950(conf)#interface fastethernet 0/1 以 17 端口为 telnet 远程登录端口

aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0

aptech2950(conf-if)#no shut

aptech2950(conf-if)#exit

aptech2950(conf)line vty 0 4 设置 0-4 个用户可以 telnet 远程登陆

aptech2950(conf-line)#login

aptech2950(conf-line)#password edge 以 edge 为远程登录的用户密码

主机设置:

ip 192.168.1.2 主机的 ip 必须和交换机端口的地址在同一网络

netmask 255.255.255.0

gate-way 192.168.1.1 网关地址是交换机端口地址

运行:

telnet 192.168.1.1

进入 telnet 远程登录界面

password : edge

aptech2950u0026gt;en

password: cisco

aptech#



二、利用三层交换机,实现不同vlan间互相通信

上面我们了解了思科交换机的基本配置命令,下面我们来看下配置案例。


案例如下:

pc1与pc2由于阻绝在了两个不同的交换机里,且在不同的vlan中,是无法通信的,那怎么办呢?


S3550-24(三层交换机)1台、S2126交换机1台、pc1在vlan10里,pc2在vlan20里,如下图所示。

思科交换机配置「思科交换机配置access命令」

VLAN间通信实验拓扑结构图



配置如下:

1、在交换机SwitchA上创建VLAN 20,并将F0/15口划分到VLAN 20中。

SwitchAu0026gt;enable

SwitchA#configure terminal

SwitchA(config)#vlan20 //创建VLAN 20

SwitchA(config-vlan)#name vlan20 //将VLAN 20 命名为vlan20

SwitchA(config)#interface f0/15 //进入F0/15接口配置模式

SwitchA(config-if)#switchport access vlan 20 //将F0/15端口划入VLAN 20

SwitchA #showvlan id 20 //验证已创建了VLAN 20并已将F0/15端口划入VLAN 20中。


2、在交换机SwitchA上与SwitchB相连的端口(此处为F0/24端口)定义为tag vlan 模式。

SwitchAu0026gt;enable

SwitchA#configure terminal

SwitchA (config)#interface f0/24 //进入接口配置模式

SwitchA (config-if)#switchport mode trunk //将F0/24口设置为tag vlan模式

SwitchA (config)#show interfaces f0/24 switch //验证F0/24口已被设置为tag vlan模式



3、在交换机SwitchB上创建VLAN 10,并将F0/5端口划入VLAN 10中。

SwitchAu0026gt;enable

SwitchA#configure terminal

SwitchB(config)#vlan 10 //创建VLAN 10

SwitchB (config-vlan)#name vlan10 //将VLAN 10 命名为vlan

SwitchB (config)#interface f0/5 //进入F0/5接口配置模式

SwitchB (config-if)#switchport access vlan10 !将F0/5端口划入VLAN 10

SwitchB #show vlan id 10 //验证已创建了VLAN 10并已将F0/5端口划入VLAN 10中



4、在交换机SwitchB上与SwitchA相连的端口(此处为F0/24端口)定义为tag vlan 模式。


SwitchAu0026gt;enable

SwitchA#configure terminal

SwitchB (config)#interface f0/24 //进入接口配置模式

SwitchB (config-if)#switchport mode trunk //将F0/24口设置为tag vlan模式

SwitchB (config)#show interfaces f0/24 switch //验证F0/24口已被设置为tag vlan模式。


5、设置三层交换机VLAN 间通讯,开启三层交换机的路由功能

SwitchAu0026gt;enable

SwitchA#configure terminal

SwitchA(config)#ip routing //开启三层交换机的路由功能


SwitchA(config) #interface vlan 10 //创建虚拟接口vlan10

SwitchA(config-if) #ip address 192.168.10.254 255.255.255.0 //配置vlan10的虚拟接口ip地址

SwitchA(config) #interface vlan 20 //创建虚拟接口vlan20

配置vlan20的虚拟接口ip地址

SwitchA(config-if) #ip address 192.168.20.254 255.255.255.0 //配置vlan20的虚拟接口ip地址


5、配置默认网关

将PC1的默认网关设置为192.168.10.254,将PC2的默认网关设置为192.168.20.254


如此,pc1与pc2便可以相互通。

本文到此结束,希望对大家有所帮助。

免责声明:本文由用户上传,如有侵权请联系删除!